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Itroduction

1 Introduction

This User Manual will show you how to install the GNU Toolchain and Eclipse, how to compile and
debug a simple example using the BlackfinOne board and PEEDI JTAG/BDM Emulator and Flash

Programmer.
The necessary software components for a Blackfin cross development are:

- GNU toolchain (compiler, linker, gdb)
- Eclipse IDE including Zylin CDT Plug-in for C/C++d  evelopment
- Java Runtime

To enable a quick start in the Blackfin cross development Ronetix provides pre-built packages for
Linux and Windows hosts:

- The GNU toolchain:
http://download.ronetix.info/toolchains/blackfin/ronetix-bfin-elf.2007R1-RC10.070525.tar.bz2

linked against gcc’s own newlib library. The bfin-e If-* toolchain
should be used to build non-kernel and non-uClibc a pplications.

http://download.ronetix.info/toolchains/blackfin/ronetix-bfin-uclinux.2007R1-RC10.070525.tar.bz2

linked against uClibc, which was built by the bfin- elf-* toolchain.
Use this to build the kernel and kernel modules. Us e this to build
all userspace applications in the FLAT format.

http://download.ronetix.info/toolchains/blackfin/ronetix-bfin-linux-uclibc.2007R1-
RC10.070525.tar.bz2
linked against uClibc, which was built by the bfin- elf-* toolchain.

Use this to build all userspace applications inRB&1C ELF format.

- The Eclipse IDE
- A simple http://download.ronetix.info/examples

The necessary setup file for a Windows host is (coming soon).
It is a Windows installer which installs the GNU toolchain, Eclipse IDE + Zylin CDT and Java.
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2 PEEDI Blackfin Emulator
Installation

PEEDI (Powerful Embedded Ethernet Debug Interface) is a solution that enables you
to debug software running on Blackfin processor cores via the JTAG port.

In order to debug you need to configure PEEDI JTAG Emulator. The configuration of PEEDI is
common for both toolchains for Linux and Windows.

You can find detailed information about PEEDI in the PEEDI’'s User Manual:
http://download.ronetix.info/peedi/doc/peedi rev.A manual.pdf

- Connect PEEDI to a free port of your LAN switch/hub using the supplied UTP patch cable.

- Connect PEEDI to the target using the supplied JTAG adapter. The JTAG adapter must be on
the PEEDI side of the JTAG cable:

Adapter JTAG cable

Target
= Ny
1

- Connect PEEDI to a COM port of your PC using the RS232 cable. Start any kind of terminal
emulation program (HyperTerminal) and set it to 115200 bauds, 8 data bits, no parity and no
flow control.

- Restart PEEDI holding pressed both front panel buttons to enter RedBoot command line.

- Use fconfig command to set the network configuration and other parameters.

1 # 8
N . %
- Restart PEEDI again for the changes to take effect

After PEEDI is up and running (this should take some seconds after reset), press and hold the
green front panel button and PEEDI will start to display its IP address on the display.

Connect to PEEDI with telnet application using the IP address from the previous statement. If
connected, you should see the PEEDI CLI prompt
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3 Toolset installation on Linux

To install the pre-built from Ronetix GNU cross-development tools:

Download the GNU tools form here:
http://download.ronetix.net/toolchain/ronetix-bfin-elf.2007R1-RC10.070525.tar.bz2
or get it from the CD.

Uncompress the archive:

The toolchain will be installed in the /usr/cross/bfin-elf directory. If want to install the toolset in another

directory make sure you have a symbolic link in the /usr/cross

1. Set a path to the /usr/cross/bfin-elf/bin: in the .bashrc file add the following:

I "#$ % $$

2. Test the toolchain installation:

& (096%
)$((”# $ %%
# *+"+, $% % $$ %- %+ . 9%-
%+ . (%% % (# (
#3 % $$ *+ £ 8 $ % %+
$ 8 % % # ,

$ %0 8 $ 8%
+ s ”$(
(%% $ / 123 .4

3. Installing Eclipse IDE

Download the Eclipse IDE from here or get it form the CD:

http://www.ronetix.at/software.html

The file eclipse.tar.bz2 includes:
- Eclipse SDK v3.2.1
- Embedded CDT v3.1 patched by Zylin
- Zylin plugin
- Java Virtual Machine v1.5.0_09

% #$ %
% $

Set a path to the /usr/local/eclipse: in the .bashrc file add the following:
I "#% % % $
4. Installing an example

Download the BF532 example from here:

)
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http://download.ronetix.info/examples

or get it from the CD.

At this point you should be able to build, debug and run applications on embedded Blackfin targets.
You can compile and debug the example manual, from the shell prompt or using Eclipse. The working
with Eclipse is explained in “Section 5: Working with Eclipse” from this manual.

5. Compiling from the shell

& '1% %+
& '1,-

(%% $$, *+% % (255267 87 9:3;55
$%% #6 $%% #

(%% % < (25526787 9:355 =2 =,

, 3 3 38%3 %$%, % 3%,
(%% % < (25526787 9:355 =2 = =
# 3 3 38%3 %BSUB#H % & % #
(%% $%$ # $%, 8% # > ?
, > $§ @A= %+, A% A * , 8 %+
%+

% 0 < 0 %+ %+

6. Debugging

From a X-console start the Insight debugger:

& $(+ %+

main.c - Source Yindows

File BERun ¥iew Control Preferences Help

FOT00 D EAS0 M1 || o
jnain. o A icin) hd| |SOURCE |
128 int main(void) A
- 129 ¢
- 130 wold (*pDhrystone) (woid) = (woid (*) (woid)) (f{unsigned int) ATI1F Dk
- 131 ATIIF DBOU Printk ("-I- Enter in main({) sectionn’r");
132
- 133 ATI1F _DBGU Printlk("-I- no MMU, I+D Caches Disablednhc");
- 134 ATI1F DisahlelCache();
- 13& ATIIF DiszbleDCache () ;
- 136 ATIIF Dhrystone () ; =1
137
- 138 ATIIF _DEGU_Printk ("‘nir-I- no MMU, I Cache Enabledinir"): ¥
P~ [ P
IF'ngram stopped at line 130 |2EIEIEIEI|:13EI| 130
I I




Installation on Linux

The following descriptions discuss the use of the default debugger toolbar buttons.

The Run button, do not use this button. Instead of this use the “Continue ” button

During the debugging process, the Run button turns into the Stop button to interrupt the
debugging.

The Continue button continues execution until a breakpoint, watchpoint or exception is
encountered, or until execution completes.

The Step button steps to next executable line of source code. Also, the Step button steps
into called functions.

The Next button steps to the next executable line of source code in the current file. Unlike
the Step button, the Next button steps over called functions.

The Finish button finishes execution of a current frame. If clicked while in a function, it

finishes the function and returns to the line that called the function.
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4 Toolset installation on Windows

Please download the GNU toolchain installer from our web site, launch it and follow the instructions.

http://www.ronetix.at/software.html (comming soon)

The setup will install:

By default, the installer provided by Ronetix installs everything necessary for developing. This
includes:

bfin-elf GNU tools (compiler, linker, and debugger)

Eclipse IDE v3.2.1 and Zylin CDT plug-in

Java run-time environment for the Eclipse

ready-to-build examples

a free TFTP server
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5 Working with Eclipse

5.1 Adding a project

Eclipse (http://www.eclipse.org) is an open-source, Java based, powerful Integrated Development
Environment (IDE). Adding the CDT plug-in (C/C++ Development Toolkit), you can edit and build C
programs using the GNU compiler toolkit. A detailed C/C++ Development User Guide for Eclipse can
be downloaded from http://www.eclipse.org/cdt or from the Ronetix site.

The Java run-time environment, Eclipse and the CDT plug-in are installed by the installer from
Ronetix. Now start Eclipse IDE using the desktop icon, the “Workspace Launcher” dialog should
appear, where you need to point the workspace folder. In our case point “C:\Program
Files\Ronetix\examples\bf532\BlackfinOne”, this way eclipse will automatically include the project files
when we create a new project. Next click OK.

& Workspace Launcher X|

Select a workspace

Eclipse Platform stares your projects in a Folder called a workspace.
hoose a workspace Folder bouse For this session,

el et la=-T R | Program FilesiRonetixhexamplesibfS321BlackfinCne j Browse... |

[~ Use this as the default and do not ask again

Now click at the "Workbench" icon at the right edge of the window.

& Java - Eclipse SDK g = 3]
File Edit Mavigate Search Project Run  “Window Help
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The next window will look like:

& Java - Eclipse SDK

_io| x|
File Edit Source Refactor Mavigate Search Project Run  MWindow Help
| C3 - |#%-0-Q- | BEHGE-|®P|E2-]5 -5 £ - T | 8 1ava
H er X Hierarchy| = = O|[ 5= outline &2 = =
£ | = <}==(> = An outline is not available.
[£/ Problems 5% Javadoc|DecIaration| o
0 errars, 0 warnings, 0infos
Descripkion 4 | Fesoutce | Path | Location |
| o | IEIEEEEE

Now you need to add as a project the BF532 example. Click File->New->Project. In the New Project
dialog select Standard Make C Project and click Next:

& Mew Project ﬂ

Select a wizard

Create a new C Project which uses a simple makefile,

Wizards:

| bype filker kext

----- [§ Jana Projeck -
""" # Java Project Fromn Existing Ant Buildfile
----- l_ﬁ Plug-in Project

-[= General

- @ Managed Make C Project
Standard Ma
H-= C++

- VS |

: _ Project

(7) = Back I Mexk = I Einish Cancel
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In the “New Project” dialog put “echo” for project name and click Finish. The echo already exists there
so all of its files will be automatically imported in the new created Eclipse project.

£ New Project |

C/Make Project ,
o
Create a Mew C Project using 'make’ to build it @

Project name: I echo

W Use default lacation

/

Location: | C:/Program Files/Ronetixlexamples/bfS32 (BlackfinOneecho Brawse, ..

(7 < Back et = | Einish I Cancel

Now Eclipse will ask you to change the perspective to C/C++, check remember my decision and click
YES:

& Open Associated Perspective? x|

This kind of project is associated with the C/C++ perspective. Do you wank
ko open this perspective nowy

¥ Remember my decision;
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Now the Eclipse window should look like:

& C/C++ - Eclipse Platform

=1alx|
File Edit Refactor Mavigate Search Project Run  Window Help
Jes- o S g6 d-6- j#$-0-Q-|® % |-  EEd
a . [t - v [T Resource
Navigator| = = = O | 2= outine 52 Mak. .. | =0
| = <><b B An outline is not available,
[LProbIems po Console|Pr0perties| :{=:€> T = m
0 errors, 1 warning, 0 infos
Descripkion  # | Resource | Path | Locakion |
=l B warnings {1 item)
& Error launching external scanner info ger echo Unknown
J T Jecha J J @| D [ & <

Use the "Project" menu and remove the checkmark at "Build Automatically":

& C/C++ - Eclipse Platform

File Edit Refackor Mavigate Search | Project Bun  ‘Window  Help

J o J Tﬁ Open Projeck

. Close Project

14 Build &l

CIC++ Proj

Active Build Configuration 2
Zlean Selected Filels)
Build Selected Eilels)
Build Praoject

Build Woaorking Set
Clean...

Build Automatically

Ckrl+-B

Create Make Target. ..
Build Make Target...

Properties

Open echo.c by double clicking on it in the echo/src folder:
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Now build the project:

& C/C++ - main.c - Eclipse Platform
File Edit Refackor Mavigake Search | Project Bun  ‘Window Help

J Fﬁ " H | o0 J 21 - J @ open Projeck
i

Zlose Project

J

R SRR

- = Build &l ctl+s
% CIC4++ Projecks 22 Mavigatar | o
Ackive Build Configuration F
P | = Zlean Selected Filels) [
EL:'E- echi Buld Selected Eile(s)
B2 inc Build Project
E‘[E? e Build Working Set 3 |
[€] main.c Cl?aﬂ' 00 _
@ startup.s Build Automatically A
d na
; @ uart.c Cteate Make Targek. ..
- 5| bFS32-ram.Id Euild Make Target. ..
i ; asw
------ | @ makefile
Propetties
|| Tore MNoulLr I, TEy 05/ 03

At this point your project should be compiled and liked to a single executable “echo.elf” file. You can
check its presence.
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5.2 Configuring and working with the Eclipse built- in debugger

First click the arrow right to the “bug” button and next “Debug...”

This opens the Debug configuration dialog. Select Embedded debug (Native) and click the New
button:
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This will change the look of the window to:

If your window does not look like the previous, follow the next two steps:

1. Enter echo for name and click Project Browse to select the echo and click OK:
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2 .Next enter echo.elf for C/C++ Application.

Now select the Debugger tab and Browse to locate “...\Ronetix\bfin-elf\bin\bfin-elf-gdb.exe”:
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Now change to the Commands tab and enter these commands considering your PEEDI IP address:

These command will tell gdb:
- to connect to your PEEDI
- to load the project executable file to the target

Next click Apply and Debug, this will start the debugger and Eclipse should ask you:

Check remember my decision and click YES.

If Eclipse doesn’t automatically switch to the Debug perspective, you can switch manually using menu
Window -> Open Perspective -> Debug
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Now the debugger is started:

Set a break point where you wish by double clicking the grey margin:
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Next click the Resume botton. The application is started and shortly it should break were the break
point is:

At this point you can continue debugging, i.e. step, put breaks, resume, etc.
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5.3 Using Insight debugger as an Eclipse externalt ool

| you prefer you can use Insight for a debugger when developing with Eclipse IDE.

For this reason you need to add it as an external tool by clicking Run->External Tools->External
Tool...

In the “External Tools” dialog select Program and click the New button:
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In the new dialog for name type “Insight”, for location click Browse File System and navigate to
“...\Ronetix\bfin-elf\bin\bfin-elf-insight.exe”, for Working Directory click Browse Workspace and select
echo and for Arguments type echo.elf.



Working with Eclipse

Now click on Common, and in the “Display in favorites menu” select Insight to add it to the Run menu
and click Apply and Close:

Now you have Insight in your Run menu.
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You have just added the Insight.

You can follow the previous procedure to add any external tool you wish to use while developing.
Now you can start Insight and debug the project.



